ArecaVSS - The Volume Shadow Copy plugin for Areca-Backup


Download ArecaVSS

Get a license for ArecaVSS (free or full)

Frequently Asked Questions (FAQ)

Tickets :

Item #15 - ERROR java.lang.ArrayIndexOutOfBoundsException: 1 [Closed - Resolved]

Everything worked on the trial, then I bought a license, put it in the folder, and it worked.

On the 30.12.2012 it still worked, and ever since the 31.12.2012 it doesn't work anymore, this is the error:
13-01-02 01:07 - ERROR
java.lang.ArrayIndexOutOfBoundsException: 1
at com.arecavss.plugin.VSSIndexHelper.cleanIndex(
at com.arecavss.plugin.ArecaVSSConfigurationAddon.ensureVSSSnapshots(
at com.application.areca.AbstractTarget.processBackup(
at com.application.areca.ActionProxy.processBackupOnTarget(
at com.application.areca.launcher.gui.Application$9.runCommand(
at com.application.areca.launcher.gui.Application$
at Source)

Areca Backup
Version 7.2.17 - November 17, 2012
java.runtime.version : 1.7.0_10-b18

The error appears on all targets, I've also tried making a fresh one with no changes besides picking a source and a destination directory and enabling VSS.

With VSS disabled it works.

Please let me know if you need any further information.
User #179 - 2013-01-02 01:14

Comments :
I might want to add:
This happens whenever I try to run a backup, and this is before the error:

13-01-02 18:00 - INFO - Starting backup on Users (15744386). Backup scheme = Incremental backup
13-01-02 18:00 - INFO - Backup in progress ...
13-01-02 18:00 - INFO - Initializing backup context ...
13-01-02 18:00 - INFO - Global source root : C:/Users
13-01-02 18:00 - INFO - Checking Areca's VSS index
13-01-02 18:00 - ERROR [snip]
User #179 - 2013-01-02 18:11

The problem has been identified; a fixed version of ArecaVSS will be delivered this week end.

Best regards
ArecaVSS staff - 2013-01-03 08:47
Hello again

This is a bug in the part of ArecaVSS that handles Volume Shadow Copies and makes sure that no obsolete copy remains on the computer.

Best regards
ArecaVSS staff - 2013-01-03 12:59

Could you test the last version of ArecaVSS (1.6) and confirm that it solves your problem ?

Thank you

Best regards
ArecaVSS staff - 2013-01-04 22:07
Add comment :
Token ID (provided to you in the verification email) :